libcgi-perl_4.51.bb 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. DESCRIPTION = "CGI.pm is a stable, complete and mature solution for processing and preparing \
  2. HTTP requests and responses. Major features including processing form \
  3. submissions, file uploads, reading and writing cookies, query string generation \
  4. and manipulation, and processing and preparing HTTP headers."
  5. HOMEPAGE = "http://search.cpan.org/~leejo/CGI-4.28/lib/CGI.pod"
  6. SECTION = "libs"
  7. LICENSE = "Artistic-2.0 | GPL-2.0"
  8. LIC_FILES_CHKSUM = "file://LICENSE;md5=415fc49abed2728f9480cd32c8d67beb"
  9. SRC_URI = "http://search.cpan.org/CPAN/authors/id/L/LE/LEEJO/CGI-${PV}.tar.gz"
  10. SRC_URI[md5sum] = "87b6cf5bc68739c9310ca501adad998e"
  11. SRC_URI[sha256sum] = "0bd215e7012f9f52e6a7d3fe695ee30ef959d796e8e53472fa0ed8c53fba600a"
  12. S = "${WORKDIR}/CGI-${PV}"
  13. inherit cpan ptest-perl
  14. RDEPENDS_${PN} += "\
  15. libhtml-parser-perl \
  16. perl-module-base \
  17. perl-module-deprecate \
  18. perl-module-if \
  19. "
  20. do_install_prepend() {
  21. # requires "-T" (taint) command line option
  22. rm -rf ${B}/t/push.t
  23. rm -rf ${B}/t/utf8.t
  24. # tests building of docs
  25. rm -rf ${B}/t/compiles_pod.t
  26. }
  27. RDEPENDS_${PN}-ptest += " \
  28. libtest-deep-perl \
  29. libtest-warn-perl \
  30. perl-module-bytes \
  31. perl-module-file-find \
  32. perl-module-filehandle \
  33. perl-module-findbin \
  34. perl-module-lib \
  35. perl-module-perlio \
  36. perl-module-perlio-scalar \
  37. perl-module-test-more \
  38. perl-module-utf8 \
  39. "
  40. RPROVIDES_${PN} += "perl-module-cgi"
  41. BBCLASSEXTEND = "native"