googletest_git.bb 1.3 KB

12345678910111213141516171819202122232425262728293031
  1. DESCRIPTION = "Google's framework for writing C++ tests"
  2. HOMEPAGE = "https://github.com/google/googletest"
  3. SECTION = "libs"
  4. LICENSE = "BSD-3-Clause"
  5. LIC_FILES_CHKSUM = "file://googlemock/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \
  6. file://googletest/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a"
  7. PV = "1.10.0"
  8. PROVIDES += "gmock gtest"
  9. S = "${WORKDIR}/git"
  10. SRCREV = "703bd9caab50b139428cea1aaff9974ebee5742e"
  11. SRC_URI = "git://github.com/google/googletest.git"
  12. inherit cmake
  13. ALLOW_EMPTY_${PN} = "1"
  14. ALLOW_EMPTY_${PN}-dbg = "1"
  15. RDEPENDS_${PN}-dev += "${PN}-staticdev"
  16. BBCLASSEXTEND = "native nativesdk"
  17. do_configure_prepend() {
  18. # explicitly use python3
  19. # the scripts are already python3 compatible since https://github.com/google/googletest/commit/d404af0d987a9c38cafce82a7e26ec8468c88361 and other fixes like this
  20. # but since this oe-core change http://git.openembedded.org/openembedded-core/commit/?id=5f8f16b17f66966ae91aeabc23e97de5ecd17447
  21. # there isn't python in HOSTTOOLS so "env python" fails
  22. sed -i 's@^#!/usr/bin/env python$@#!/usr/bin/env python3@g' ${S}/googlemock/scripts/*py ${S}/googlemock/scripts/generator/*py ${S}/googlemock/scripts/generator/cpp/*py ${S}/googlemock/test/*py ${S}/googletest/scripts/*py ${S}/googletest/test/*py
  23. }