catch2_2.9.2.bb 717 B

12345678910111213141516171819202122
  1. DESCRIPTION = "A modern, C++-native, header-only, test framework for unit-tests, \
  2. TDD and BDD - using C++11, C++14, C++17 and later."
  3. AUTHOR = "Phil Nash, Martin Horenovsky and others"
  4. HOMEPAGE = "https://github.com/catchorg/Catch2"
  5. LICENSE = "BSL-1.0"
  6. LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
  7. SRC_URI = "git://github.com/catchorg/Catch2.git"
  8. SRCREV = "2c869e17e4803d30b3d5ca5b0d76387b9db97fa5"
  9. S = "${WORKDIR}/git"
  10. inherit cmake python3native
  11. do_install_append() {
  12. rm ${D}${datadir}/Catch2/lldbinit
  13. rm ${D}${datadir}/Catch2/gdbinit
  14. rmdir ${D}${datadir}/Catch2/
  15. }
  16. # Header-only library
  17. RDEPENDS_${PN}-dev = ""
  18. RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"