zbar_git.bb 835 B

12345678910111213141516171819202122232425262728293031
  1. DESCRIPTION = "2D barcode scanner toolkit."
  2. SECTION = "graphics"
  3. LICENSE = "LGPL-2.1"
  4. DEPENDS = "pkgconfig intltool-native libpng jpeg"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=4015840237ca7f0175cd626f78714ca8"
  6. PV = "0.10+git${SRCPV}"
  7. # iPhoneSDK-1.3.1 tag
  8. SRCREV = "67003d2a985b5f9627bee2d8e3e0b26d0c474b57"
  9. SRC_URI = "git://github.com/ZBar/Zbar \
  10. file://0001-make-relies-GNU-extentions.patch \
  11. "
  12. S = "${WORKDIR}/git"
  13. inherit autotools pkgconfig
  14. PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
  15. PACKAGECONFIG[x11] = "--with-x,-without-x,libxcb libx11 libsm libxau libxext libxv libice libxdmcp"
  16. EXTRA_OECONF = "--without-imagemagick --without-qt --without-python --disable-video --without-gtk"
  17. CPPFLAGS += "-Wno-error"
  18. do_install_append() {
  19. #remove usr/bin if empty
  20. rmdir ${D}${bindir}
  21. }