uthash_2.2.0.bb 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. SUMMARY = "Hash table and linked list for C structures"
  2. DESCRIPTION = " uthash-dev provides a hash table implementation using C preprocessor macros.\n\
  3. This package also includes:\n\
  4. * utlist.h provides linked list macros for C structures\n\
  5. * utarray.h implements dynamic arrays using macros\n\
  6. * utstring.h implements a basic dynamic string\n\
  7. "
  8. HOMEPAGE = "https://troydhanson.github.io/uthash/"
  9. SECTION = "base"
  10. LICENSE = "BSD-1-Clause"
  11. LIC_FILES_CHKSUM = "file://LICENSE;md5=6891c324eb59289db33bac74d4cbb0d4"
  12. SRCREV = "66e2668795d0aaf4977523f828e548470a680c33"
  13. SRC_URI = "\
  14. git://github.com/troydhanson/${BPN}.git \
  15. file://run-ptest \
  16. "
  17. S = "${WORKDIR}/git"
  18. inherit ptest
  19. do_compile[noexec] = "1"
  20. do_compile_ptest() {
  21. oe_runmake -C tests tests_only TEST_TARGET=
  22. }
  23. do_install () {
  24. install -dm755 ${D}${includedir}
  25. install -m0644 src/*.h ${D}${includedir}
  26. }
  27. do_install_ptest() {
  28. install -dm755 ${D}${PTEST_PATH}/tests
  29. install -m0755 tests/test*[0-9] ${D}${PTEST_PATH}/tests
  30. install -m0644 tests/test*[0-9].ans ${D}${PTEST_PATH}/tests
  31. install -m0644 tests/test*[0-9].dat ${D}${PTEST_PATH}/tests
  32. }
  33. # The main package is empty and non-existent, so -dev
  34. # should not depend on it...
  35. RDEPENDS_${PN}-dev = ""
  36. RDEPENDS_${PN}-ptest_remove = "${PN}"
  37. BBCLASSEXTEND = "native"