system-config-keyboard_1.4.0.bb 842 B

12345678910111213141516171819202122232425262728
  1. DESCRIPTION = "a graphical user interface that allows the user to \
  2. change the default keyboard of the system"
  3. LICENSE = "GPLv2+"
  4. LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
  5. SRC_URI = "https://fedorahosted.org/releases/s/y/${BPN}/${BP}.tar.bz2"
  6. SRC_URI[md5sum] = "c267db0ee7a2131ba418399dc17f9e72"
  7. SRC_URI[sha256sum] = "218c883e4e2bfcc82bfe07e785707b5c2ece28df772f2155fd044b9bb1614284"
  8. inherit python3-dir gettext
  9. DEPENDS += "intltool-native gettext-native"
  10. EXTRA_OEMAKE = " \
  11. PYTHON='${STAGING_BINDIR_NATIVE}'/python-native/python \
  12. PYTHON_SITELIB=${PYTHON_SITEPACKAGES_DIR} \
  13. "
  14. do_install() {
  15. oe_runmake 'DESTDIR=${D}' install
  16. }
  17. do_install_append_class-native() {
  18. rm -rf ${D}/usr
  19. }
  20. FILES_${PN} += " \
  21. ${libdir}/python${PYTHON_BASEVERSION}/* \
  22. ${datadir}/* \
  23. "
  24. BBCLASSEXTEND = "native"