onig_6.9.4.bb 1.1 KB

123456789101112131415161718192021222324252627282930313233
  1. SUMMARY = "Regular expressions library"
  2. DESCRIPTION = "Oniguruma is a modern and flexible regular expressions library. \
  3. It encompasses features from different regular expression \
  4. implementations that traditionally exist in different languages. \
  5. Character encoding can be specified per regular expression object."
  6. HOMEPAGE = "https://github.com/kkos/oniguruma"
  7. LICENSE = "BSD-2-Clause"
  8. LIC_FILES_CHKSUM = "file://COPYING;md5=1ee043784bdce7503e619b2d1a85798b"
  9. SRC_URI = "\
  10. https://github.com/kkos/oniguruma/releases/download/v${PV}/${BP}.tar.gz \
  11. file://0001-build-don-t-link-against-host-system-libraries.patch \
  12. file://0001-build-enable-serial-tests-automake-option-for-ptest.patch \
  13. file://run-ptest \
  14. "
  15. SRC_URI[md5sum] = "a12d2fe997b789bd87cf63799c091879"
  16. SRC_URI[sha256sum] = "4669d22ff7e0992a7e93e116161cac9c0949cd8960d1c562982026726f0e6d53"
  17. BINCONFIG = "${bindir}/onig-config"
  18. inherit autotools binconfig-disabled ptest
  19. BBCLASSEXTEND = "native"
  20. do_compile_ptest() {
  21. oe_runmake -C test buildtest-TESTS
  22. }
  23. do_install_ptest() {
  24. mkdir -p ${D}${PTEST_PATH}/tests
  25. install -m 0755 -t ${D}${PTEST_PATH}/tests/ ${B}/test/.libs/*
  26. }