minini_1.2.b.bb 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. SUMMARY = "A minimal INI file parser"
  2. DESCRIPTION = "minIni is a programmer's library to read and write INI files in \
  3. embedded systems. minIni takes little resources, has a deterministic memory \
  4. footprint and can be configured for various kinds of file I/O libraries. minIni \
  5. provides functionality for reading, writing and deleting keys from an INI file, \
  6. all in 830 lines of (commented) source code (version 1.2) in C (the code also \
  7. compiles in C++ and comes with a wrapper class)."
  8. HOMEPAGE = "https://code.google.com/p/minini/"
  9. # License is Apache 2.0 with an exception to allow object code built from
  10. # unmodified original sources to be distributed more freely. See LICENSE
  11. # file for details.
  12. LICENSE = "Apache-2.0"
  13. LIC_FILES_CHKSUM = "file://LICENSE;md5=eb21481ad45c5578ae8c8d37b8c8d76d"
  14. SRC_URI = "https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/minini/minIni_12b.zip;subdir=${BP}"
  15. SRC_URI[md5sum] = "32740621098e3f0a321c7c23f4bcbc5d"
  16. SRC_URI[sha256sum] = "b08839af74acb36061fb76e1123bf56711bc5cf7a08b32e189b0ad78a2e888e2"
  17. do_configure[noexec] = "1"
  18. do_compile() {
  19. ${CC} ${CFLAGS} -fPIC -c minIni.c -o minIni.o
  20. ${CC} ${LDFLAGS} -shared -Wl,-soname,libminini.so.0 minIni.o -o libminini.so.0.0
  21. }
  22. do_install () {
  23. install -d ${D}${libdir}
  24. install -m 0644 libminini.so.0.0 ${D}${libdir}/
  25. ln -s libminini.so.0.0 ${D}${libdir}/libminini.so
  26. ln -s libminini.so.0.0 ${D}${libdir}/libminini.so.0
  27. install -d ${D}${includedir}/minini
  28. install -m 0644 minIni.h ${D}${includedir}/minini/
  29. install -m 0644 minGlue-stdio.h ${D}${includedir}/minini/minGlue.h
  30. }