mcelog_170.bb 1.1 KB

1234567891011121314151617181920212223242526272829303132333435
  1. SUMMARY = "mcelog daemon accounts memory and some other errors in various ways."
  2. DESCRIPTION = "mcelog is required by both 32bit x86 Linux kernels (since 2.6.30) \
  3. and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks \
  4. and should run on all Linux systems that need error handling."
  5. HOMEPAGE = "http://mcelog.org/"
  6. SECTION = "System Environment/Base"
  7. SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http; \
  8. file://run-ptest \
  9. "
  10. SRCREV = "391abaac9bdff385934b18134789bcc98b0adeb7"
  11. LICENSE = "GPLv2"
  12. LIC_FILES_CHKSUM = "file://README.md;md5=74bb47b9a68850cb398665cf78b31de6"
  13. S = "${WORKDIR}/git"
  14. inherit autotools-brokensep ptest
  15. COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
  16. do_install_append() {
  17. install -d ${D}${sysconfdir}/cron.hourly
  18. install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/
  19. sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron
  20. }
  21. do_install_ptest() {
  22. install -d ${D}${PTEST_PATH}
  23. cp -r ${S}/tests ${S}/input ${D}${PTEST_PATH}
  24. sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test
  25. }
  26. RDEPENDS_${PN}-ptest += "make bash mce-inject"