libutempter.bb 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. SUMMARY = "A privileged helper for utmp/wtmp updates"
  2. DESCRIPTION = "\
  3. This library provides interface for terminal emulators such as \
  4. screen and xterm to record user sessions to utmp and wtmp files."
  5. HOMEPAGE = "ftp://ftp.altlinux.org/pub/people/ldv/utempter"
  6. SECTION = "System Environment/Libraries"
  7. LICENSE = "GPLv2 & GPLv2+ & LGPLv2 & MIT"
  8. LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
  9. SRCREV = "3ef74fff310f09e2601e241b9f042cd39d591018"
  10. PV = "1.1.6-alt2+git${SRCPV}"
  11. SRC_URI = "git://git.altlinux.org/people/ldv/packages/libutempter.git \
  12. file://0001-Fix-macro-error.patch \
  13. file://0002-Proper-macro-path-generation.patch \
  14. file://libutempter-remove-glibc-assumption.patch \
  15. "
  16. S = "${WORKDIR}/git/${BPN}"
  17. CFLAGS += "-DLIBEXECDIR=${libexecdir}"
  18. do_compile() {
  19. oe_runmake \
  20. libdir=${libdir} \
  21. libexecdir=${libexecdir}
  22. }
  23. do_install() {
  24. oe_runmake install \
  25. DESTDIR=${D} \
  26. libdir="${libdir}" \
  27. libexecdir="${libexecdir}" \
  28. includedir=${includedir} \
  29. mandir=${mandir}
  30. rm -f ${D}${libdir}/*.a
  31. }
  32. FILES_${PN} = "${libdir}/*.so.*"
  33. FILES_${PN} += "${libexecdir}/utempter/utempter"
  34. FILES_${PN}-dbg += "${libexecdir}/utempter/.debug/utempter"