liburing_0.7.bb 1.1 KB

1234567891011121314151617181920212223242526
  1. SUMMARY = "This is the io_uring library, liburing."
  2. DESCRIPTION = "liburing provides helpers to setup and teardown io_uring \
  3. instances, and also a simplified interface for applications that don't need \
  4. (or want) to deal with the full kernel side implementation."
  5. HOMEPAGE = "https://github.com/axboe/liburing"
  6. BUGTRACKER = "https://github.com/axboe/liburing/issues"
  7. SECTION = "libs"
  8. LICENSE = "LGPLv2.1 | MIT"
  9. LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=d51b5805e2a675685e6a66ca50904cf9"
  10. SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https \
  11. file://0001-test-Fix-build-on-32bit-architectures-with-6bit-time.patch \
  12. "
  13. SRCREV = "45f0735219a615ae848033c47c7e2d85d101d43e"
  14. S = "${WORKDIR}/git"
  15. DEPENDS_append_libc-musl = " libucontext"
  16. XCFLAGS = "-pthread"
  17. XCFLAGS_append_libc-musl = " -lucontext"
  18. EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'"
  19. do_install () {
  20. oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir}
  21. }