libssh_0.8.9.bb 928 B

1234567891011121314151617181920212223242526272829303132333435
  1. SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
  2. HOMEPAGE = "http://www.libssh.org"
  3. SECTION = "libs"
  4. LICENSE = "LGPLv2.1"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=dabb4958b830e5df11d2b0ed8ea255a0"
  6. DEPENDS = "zlib openssl libgcrypt"
  7. SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=stable-0.8"
  8. SRCREV = "04685a74df9ce1db1bc116a83a0da78b4f4fa1f8"
  9. S = "${WORKDIR}/git"
  10. inherit cmake
  11. PACKAGECONFIG ??=""
  12. PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
  13. ARM_INSTRUCTION_SET_armv5 = "arm"
  14. EXTRA_OECMAKE = " \
  15. -DWITH_GCRYPT=1 \
  16. -DWITH_PCAP=1 \
  17. -DWITH_SFTP=1 \
  18. -DWITH_ZLIB=1 \
  19. -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
  20. "
  21. do_configure_prepend () {
  22. # Disable building of examples
  23. sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
  24. || bbfatal "Failed to disable examples"
  25. }
  26. TOOLCHAIN = "gcc"