libgpiod_1.6.2.bb 1.3 KB

123456789101112131415161718192021222324252627282930313233
  1. SUMMARY = "C library and tools for interacting with the linux GPIO character device"
  2. AUTHOR = "Bartosz Golaszewski <bgolaszewski@baylibre.com>"
  3. LICENSE = "LGPLv2.1+"
  4. LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
  5. SRC_URI = "https://www.kernel.org/pub/software/libs/${BPN}/${BP}.tar.xz"
  6. SRC_URI[md5sum] = "4765470becb619fead3cdaeac61b9a77"
  7. SRC_URI[sha256sum] = "c601e71846f5ab140c83bc757fdd62a4fda24a9cee39cc5e99c96ec2bf1b06a9"
  8. inherit autotools pkgconfig python3native
  9. PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev glib-2.0 catch2"
  10. PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx"
  11. PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,python3"
  12. # Enable cxx bindings by default.
  13. PACKAGECONFIG ?= "cxx"
  14. # Always build tools - they don't have any additional
  15. # requirements over the library.
  16. EXTRA_OECONF = "--enable-tools"
  17. DEPENDS += "autoconf-archive-native"
  18. PACKAGES =+ "${PN}-tools libgpiodcxx"
  19. FILES_${PN}-tools = "${bindir}/*"
  20. FILES_libgpiodcxx = "${libdir}/libgpiodcxx.so.*"
  21. PACKAGES =+ "${PN}-python"
  22. FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
  23. RRECOMMENDS_PYTHON = "${@bb.utils.contains('PACKAGECONFIG', 'python3', '${PN}-python', '',d)}"
  24. RRECOMMENDS_${PN}-python += "${RRECOMMENDS_PYTHON}"