lcov_1.14.bb 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. SUMMARY = "A graphical front-end for gcov"
  2. HOMEPAGE = "http://ltp.sourceforge.net/coverage/lcov.php"
  3. DESCRIPTION = "LCOV is a graphical front-end for GCC's coverage testing \
  4. tool gcov. It collects gcov data for multiple source files and creates \
  5. HTML pages containing the source code annotated with coverage information. \
  6. It also adds overview pages for easy navigation within the file structure. \
  7. LCOV supports statement, function and branch coverage measurement."
  8. LICENSE = "GPL-2.0"
  9. LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
  10. RDEPENDS_${PN} += " \
  11. libjson-perl \
  12. libperlio-gzip-perl \
  13. perl \
  14. perl-module-filehandle \
  15. perl-module-getopt-std \
  16. perl-module-digest-md5 \
  17. perl-module-digest-sha \
  18. perl-module-constant \
  19. perl-module-cwd \
  20. perl-module-errno \
  21. perl-module-file-basename \
  22. perl-module-file-copy \
  23. perl-module-file-find \
  24. perl-module-file-path \
  25. perl-module-file-spec \
  26. perl-module-file-spec-functions \
  27. perl-module-file-spec-unix \
  28. perl-module-file-temp \
  29. perl-module-getopt-long \
  30. perl-module-list-util \
  31. perl-module-mro \
  32. perl-module-overload \
  33. perl-module-overloading \
  34. perl-module-overload-numbers \
  35. perl-module-parent \
  36. perl-module-pod-usage \
  37. perl-module-posix \
  38. perl-module-re \
  39. perl-module-safe \
  40. perl-module-scalar-util \
  41. perl-module-term-cap \
  42. perl-module-text-parsewords \
  43. perl-module-tie-hash \
  44. "
  45. RDEPENDS_${PN}_append_class-target = " \
  46. gcov \
  47. gcov-symlinks \
  48. "
  49. SRC_URI = " \
  50. http://downloads.sourceforge.net/ltp/${BP}.tar.gz \
  51. file://0001-geninfo-Add-intermediate-text-format-support.patch \
  52. file://0002-geninfo-Add-intermediate-JSON-format-support.patch \
  53. "
  54. SRC_URI[md5sum] = "0220d01753469f83921f8f41ae5054c1"
  55. SRC_URI[sha256sum] = "14995699187440e0ae4da57fe3a64adc0a3c5cf14feab971f8db38fb7d8f071a"
  56. do_install() {
  57. oe_runmake install PREFIX=${D}${prefix} CFG_DIR=${D}${sysconfdir}
  58. }
  59. BBCLASSEXTEND = "native nativesdk"