gsoap_2.8.106.bb 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. DESCRIPTION = "The gSOAP toolkit provides a unique SOAP-to-C/C++ language binding \
  2. for the development of SOAP Web Services and clients."
  3. SECTION = "devel"
  4. LICENSE = "GPL-2.0-with-OpenSSL-exception"
  5. LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4f40a941379143186f9602242c3fb729 \
  6. file://GPLv2_license.txt;md5=a33672dbe491b6517750a0389063508b"
  7. SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}2/${BPN}_${PV}.zip \
  8. "
  9. SRC_URI[md5sum] = "0925d25bc455047b01d4fe9814d30173"
  10. SRC_URI[sha256sum] = "4e74838baf5437e95ae17aa3efb48bd0621f483bff4424f6255fcf327ff80765"
  11. inherit autotools
  12. BBCLASSEXTEND = "native"
  13. S = "${WORKDIR}/${BPN}-2.8"
  14. PARALLEL_MAKE = ""
  15. EXTRA_OEMAKE_class-target = "SOAP=${STAGING_BINDIR_NATIVE}/soapcpp2"
  16. DEPENDS = "openssl zlib flex bison bison-native"
  17. DEPENDS_append_class-target = " gsoap-native"
  18. do_install_append() {
  19. install -d ${D}${libdir}
  20. for lib in libgsoapssl libgsoapssl++ libgsoap libgsoapck++ libgsoap++ libgsoapck
  21. do
  22. oe_libinstall -C gsoap $lib ${D}${libdir}
  23. done
  24. }
  25. do_install_class-native() {
  26. oe_runmake DESTDIR=${D} BINDIR=${D}${bindir} install
  27. }
  28. FILES_${PN} = "${bindir}/wsdl2h ${bindir}/soapcpp2"
  29. FILES_${PN} += "${datadir}"
  30. FILES_${PN}-staticdev = "${libdir}"
  31. FILES_${PN}-dev = "${includedir}"
  32. RRECOMMENDS_${PN}-dev = "${PN}-staticdev"