gperftools_2.8.1.bb 2.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. SUMMARY = "Fast, multi-threaded malloc() and nifty performance analysis tools"
  2. HOMEPAGE = "https://github.com/gperftools/gperftools"
  3. LICENSE = "BSD-3-Clause"
  4. LIC_FILES_CHKSUM = "file://COPYING;md5=762732742c73dc6c7fbe8632f06c059a"
  5. SRCREV = "d8eb315fb18f6fb0d6efa923401f166343727bc6"
  6. SRC_URI = "git://github.com/gperftools/gperftools \
  7. file://0001-Support-Atomic-ops-on-clang.patch \
  8. file://0001-fix-build-with-musl-libc.patch \
  9. file://0001-disbale-heap-checkers-and-debug-allocator-on-musl.patch \
  10. file://disable_libunwind_aarch64.patch \
  11. file://sgidef.patch \
  12. file://0001-profile-handler-Specify-libc-specific-thread_id.patch \
  13. "
  14. inherit autotools
  15. S = "${WORKDIR}/git"
  16. # On mips, we have the following error.
  17. # do_page_fault(): sending SIGSEGV to ls for invalid read access from 00000008
  18. # Segmentation fault (core dumped)
  19. COMPATIBLE_HOST_mipsarch = "null"
  20. COMPATIBLE_HOST_riscv64 = "null"
  21. COMPATIBLE_HOST_riscv32 = "null"
  22. # Disable thumb1
  23. # {standard input}: Assembler messages:
  24. # {standard input}:434: Error: lo register required -- `ldr pc,[sp]'
  25. # Makefile:4538: recipe for target 'src/base/libtcmalloc_la-linuxthreads.lo' failed
  26. ARM_INSTRUCTION_SET_armv5 = "arm"
  27. ARM_INSTRUCTION_SET_toolchain-clang_arm = "arm"
  28. PACKAGECONFIG ?= "libunwind static"
  29. PACKAGECONFIG_remove_arm_libc-musl = "libunwind"
  30. PACKAGECONFIG_remove_riscv64 = "libunwind"
  31. PACKAGECONFIG_remove_riscv32 = "libunwind"
  32. PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind"
  33. PACKAGECONFIG[static] = "--enable-static,--disable-static,"
  34. PACKAGE_BEFORE_PN += "libtcmalloc-minimal"
  35. FILES_libtcmalloc-minimal = "${libdir}/libtcmalloc_minimal*${SOLIBS} ${libdir}/libtcmalloc_minimal_debug*${SOLIBS}"
  36. # pprof tool requires Getopt::long and POSIX perl5 modules.
  37. # Also runs `objdump` on each cpuprofile data file
  38. RDEPENDS_${PN} += "binutils perl-module-getopt-long perl-module-posix"
  39. RDEPENDS_${PN} += "libtcmalloc-minimal (= ${EXTENDPKGV})"