enca_1.9.bb 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. SUMMARY = "Enca is an Extremely Naive Charset Analyser"
  2. SECTION = "libs"
  3. HOMEPAGE = "http://trific.ath.cx/software/enca/"
  4. DEPENDS += "gettext-native"
  5. LICENSE = "GPLv2"
  6. LIC_FILES_CHKSUM = "file://COPYING;md5=24b9569831c46d4818450b55282476b4"
  7. SRC_URI = "http://www.sourcefiles.org/Networking/Tools/Miscellanenous/enca-${PV}.tar.bz2 \
  8. file://configure-hack.patch \
  9. file://dont-run-tests.patch \
  10. file://configure-remove-dumbness.patch \
  11. file://makefile-remove-tools.patch \
  12. file://libenca-003-iconv.patch "
  13. SRC_URI[md5sum] = "b3581e28d68d452286fb0bfe58bed3b3"
  14. SRC_URI[sha256sum] = "02acfef2b24a9c842612da49338138311f909f1cd33933520c07b8b26c410f4d"
  15. inherit autotools
  16. do_configure_prepend() {
  17. # remove failing test which checks for something that isn't even used
  18. sed -i -e '/ye_FUNC_SCANF_MODIF_SIZE_T/d' ${S}/configure.ac
  19. }
  20. do_configure_append() {
  21. sed -i s:-I/usr/include::g ${B}/Makefile
  22. sed -i s:-I/usr/include::g ${B}/*/Makefile
  23. }
  24. do_compile() {
  25. cd ${S}/tools && ${BUILD_CC} -o make_hash make_hash.c
  26. cd ${B}
  27. oe_runmake
  28. }