atop_2.4.0.bb 2.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. SUMMARY = "Monitor for system resources and process activity"
  2. DESCRIPTION = "Atop is an ASCII full-screen performance monitor for Linux that \
  3. is capable of reporting the activity of all processes (even if processes have \
  4. finished during the interval), daily logging of system and process activity for \
  5. long-term analysis, highlighting overloaded system resources by using colors, \
  6. etc. At regular intervals, it shows system-level activity related to the CPU, \
  7. memory, swap, disks (including LVM) and network layers, and for every process \
  8. (and thread) it shows e.g. the CPU utilization, memory growth, disk \
  9. utilization, priority, username, state, and exit code."
  10. HOMEPAGE = "http://www.atoptool.nl"
  11. SECTION = "console/utils"
  12. LICENSE = "GPLv2"
  13. LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
  14. DEPENDS = "ncurses zlib"
  15. SRC_URI = "http://www.atoptool.nl/download/${BP}.tar.gz \
  16. ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'file://volatiles.atop.conf', 'file://volatiles.99_atop', d)} \
  17. file://fix-permissions.patch \
  18. file://sysvinit-implement-status.patch \
  19. file://0001-atop.daily-atop.init-atop-pm.sh-Avoid-using-bash.patch \
  20. "
  21. SRC_URI[md5sum] = "1077da884ed94f2bc3c81ac3ab970436"
  22. SRC_URI[sha256sum] = "be1c010a77086b7d98376fce96514afcd73c3f20a8d1fe01520899ff69a73d69"
  23. do_compile() {
  24. oe_runmake all
  25. }
  26. do_install() {
  27. if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
  28. make DESTDIR=${D} VERS=${PV} SYSDPATH=${systemd_system_unitdir} \
  29. PMPATHD=${systemd_unitdir}/system-sleep systemdinstall
  30. install -d ${D}${sysconfdir}/tmpfiles.d
  31. install -m 644 ${WORKDIR}/volatiles.atop.conf ${D}${sysconfdir}/tmpfiles.d/atop.conf
  32. rm -f ${D}${systemd_system_unitdir}/atopacct.service
  33. else
  34. make DESTDIR=${D} VERS=${PV} sysvinstall
  35. install -d ${D}${sysconfdir}/default/volatiles
  36. install -m 644 ${WORKDIR}/volatiles.99_atop ${D}${sysconfdir}/default/volatiles/99_atop
  37. rm -f ${D}${sysconfdir}/init.d/atopacct
  38. fi
  39. # remove atopacct related files
  40. rm -rf ${D}${sbindir} ${D}${mandir}/man8
  41. }
  42. inherit systemd
  43. SYSTEMD_SERVICE_${PN} = "atop.service atopgpu.service"
  44. SYSTEMD_AUTO_ENABLE = "disable"
  45. FILES_${PN} += "${systemd_unitdir}/system-sleep"
  46. RDEPENDS_${PN} = "procps"