tcsh_6.22.03.bb 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. DESCRIPTION = "TENEX C Shell, an enhanced version of Berkeley csh \
  2. The TENEX C Shell is an enhanced version of the Berkeley Unix C shell. \
  3. It includes all features of 4.4BSD C shell, plus a command-line editor, \
  4. programmable word completion, spelling correction and more."
  5. HOMEPAGE = "http://www.tcsh.org/"
  6. LICENSE = "BSD-3-Clause"
  7. LIC_FILES_CHKSUM = "file://Copyright;md5=575cf2715c3bf894e1f79aec1d4eaaf5"
  8. SECTION = "base"
  9. DEPENDS = "ncurses virtual/crypt gettext-native"
  10. SRC_URI = " \
  11. https://astron.com/pub/${BPN}/${BP}.tar.gz \
  12. file://0001-Enable-system-malloc-on-all-linux.patch \
  13. file://0002-Add-debian-csh-scripts.patch \
  14. "
  15. SRC_URI[md5sum] = "c9387b7c8cf958956e75b1fa4e59b612"
  16. SRC_URI[sha256sum] = "be2cfd653d2a0c7f506d2dd14c12324ba749bd484037be6df44a3973f52262b7"
  17. EXTRA_OEMAKE += "CC_FOR_GETHOST='${BUILD_CC}'"
  18. inherit autotools
  19. do_compile_prepend() {
  20. oe_runmake CC_FOR_GETHOST='${BUILD_CC}' CFLAGS='${BUILD_CFLAGS}' gethost
  21. }
  22. do_install_append () {
  23. oe_runmake install.man DESTDIR=${D}
  24. install -d ${D}${base_bindir}
  25. ln -s /usr/bin/tcsh ${D}${base_bindir}/tcsh
  26. ln -s /usr/bin/tcsh ${D}${base_bindir}/csh
  27. install -d ${D}${sysconfdir}/csh/login.d
  28. install -m 0644 ${S}/csh.cshrc ${S}/csh.login ${S}/csh.logout ${S}/complete.tcsh ${D}${sysconfdir}
  29. install -D -m 0644 ${S}/csh-mode.el ${D}${datadir}/emacs/site-lisp/csh-mode.el
  30. }
  31. FILES_${PN} += "${datadir}/emacs/site-lisp/csh-mode.el"
  32. pkg_postinst_${PN} () {
  33. #!/bin/sh -e
  34. echo /usr/bin/tcsh >> $D/etc/shells
  35. echo /usr/bin/csh >> $D/etc/shells
  36. }