yavta_git.bb 741 B

12345678910111213141516171819202122232425
  1. SUMMARY = "Yet Another V4L2 Test Application"
  2. LICENSE = "GPLv2"
  3. LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe"
  4. SRC_URI = "git://git.ideasonboard.org/yavta.git \
  5. file://0001-Add-stdout-mode-to-allow-streaming-over-the-network-.patch"
  6. SRCREV = "7e9f28bedc1ed3205fb5164f686aea96f27a0de2"
  7. PV = "0.0"
  8. PR = "r2"
  9. S = "${WORKDIR}/git"
  10. EXTRA_OEMAKE = "-e MAKEFLAGS="
  11. # The yavta sources include copies of the headers required to build in the
  12. # include directory. The Makefile uses CFLAGS to include these, but since
  13. # we override the CFLAGS then we need to add this include path back in.
  14. CFLAGS += "-I${S}/include"
  15. do_install() {
  16. install -d ${D}${bindir}
  17. install -m 0755 yavta ${D}${bindir}
  18. }