pm-graph_5.5.bb 1.3 KB

12345678910111213141516171819202122232425262728293031323334
  1. SUMMARY = "Timing analysis tools for suspend/resume/boot"
  2. DESCRIPTION = "This tool suite is designed to assist kernel and OS developers \
  3. in optimizing their linux stack's suspend/resume & boot time."
  4. HOMEPAGE = "https://01.org/pm-graph"
  5. LICENSE = "GPL-2"
  6. LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
  7. SRCREV = "cf59527dc24fdd2f314ae4dcaeb3d68a117988f6"
  8. SRC_URI = "git://github.com/intel/pm-graph.git \
  9. file://0001-Makefile-fix-multilib-build-failure.patch \
  10. file://0001-sleepgraph.py-use-python3.patch \
  11. file://0001-sleepgraph-add-support-for-RT-kernel-ftrace-flags.patch \
  12. "
  13. S = "${WORKDIR}/git"
  14. # Apart from the listed RDEPENDS, analyze-suspend depends on some features
  15. # provided by the kernel. These options are:
  16. # - CONFIG_PM_DEBUG=y
  17. # - CONFIG_PM_SLEEP_DEBUG=y
  18. # - CONFIG_FTRACE=y
  19. # - CONFIG_FUNCTION_TRACER=y
  20. # - CONFIG_FUNCTION_GRAPH_TRACER=y
  21. COMPATIBLE_HOST='(i.86|x86_64).*'
  22. EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D} BASELIB=${baselib}"
  23. do_install() {
  24. oe_runmake install
  25. install -Dm 0755 ${S}/analyze_suspend.py ${D}${bindir}/analyze_suspend.py
  26. }
  27. RDEPENDS_${PN} += "python3-core python3-threading python3-datetime python3-compression"
  28. RPROVIDES_${PN} = "analyze-suspend"
  29. BBCLASSEXTEND = "native nativesdk"