xserver-common_1.34.bb 1.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. SUMMARY = "Common X11 scripts and support files"
  2. LICENSE = "GPLv2"
  3. LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
  4. PR = "r9"
  5. # we are using a gpe-style Makefile
  6. inherit features_check gpe
  7. REQUIRED_DISTRO_FEATURES = "x11"
  8. SRC_URI[md5sum] = "82f2f84cd96610e8f7b92c700cd31c14"
  9. SRC_URI[sha256sum] = "cd04c33418f776b1e13fcc7af3d6bd0c7cccd03fbabd7dbcd97f88166cc34210"
  10. SRC_URI_append = " \
  11. file://0001-COPYING-add-GPLv2-license-file.patch \
  12. file://0002-add-setdpi-Xinit.d-script.patch \
  13. file://0006-add-support-for-etc-X11-xserver-system.patch \
  14. file://0007-use-own-functions-file-instead-etc-init.d-functions.patch \
  15. file://0008-xserver-common-add-dpi-and-nocursor-params-for-gta01.patch \
  16. file://0009-xserver-common-add-support-for-n900-alias-nokia_rx-5.patch \
  17. file://0010-xserver-common-add-support-for-nexus-S-alias-herring.patch \
  18. file://0011-xserver-common-add-support-for-nexus-one-alias-mahim.patch \
  19. file://0012-xserver-common-add-support-for-gta04-alias-OpenPhoen.patch \
  20. file://0013-xserver-common-add-support-for-tuna-alias-Galaxy-Nex.patch \
  21. file://0015-xserver-common-disable-TCP-connections.patch \
  22. file://0001-Don-t-install-Xsession-or-Xserver.patch \
  23. "
  24. do_install_append() {
  25. sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/xserver-common
  26. # Rename all Xsession files not ending with .sh
  27. # Unfortunatelly when xinput-calibrator was moved to oe-core
  28. # its Xsession file got name 30xinput_calibrate.sh and ls -X sorts it
  29. # last, not respecting numbers for sorting them
  30. for i in ${D}/${sysconfdir}/X11/Xsession.d/*; do
  31. echo $i | grep '.sh$' || mv $i $i.sh
  32. done
  33. }
  34. RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo fbset xinput-calibrator"
  35. RCONFLICTS_${PN} = "xserver-kdrive-common x11-common"
  36. RREPLACES_${PN} = "xserver-kdrive-common x11-common"