ttf-pt-sans_1.1.bb 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. SUMMARY = "PT Sans Fonts"
  2. DESCRIPTION = "The PT Sans TTF font set"
  3. HOMEPAGE = "http://www.paratype.com/public/"
  4. SECTION = "x11/fonts"
  5. LICENSE = "ParaTypeFFL-1.3"
  6. LIC_FILES_CHKSUM = "file://../PT%20Free%20Font%20License_eng.txt;md5=d720f3a281ed81c3f4cfc465e11b1d0d"
  7. inherit allarch fontcache
  8. # Downloading from fedora because upstream doesn't version its zip file
  9. # and causes hash build failures
  10. SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/paratype-pt-sans-fonts/PTSans.zip/c3f5a0e20a75cf628387510a720924a7/PTSans.zip"
  11. SRC_URI[md5sum] = "c3f5a0e20a75cf628387510a720924a7"
  12. SRC_URI[sha256sum] = "0164f824e03c32c99e8a225853ec168893a04a09ade132e93a674e85ae033b2e"
  13. do_install () {
  14. install -d ${D}${datadir}/fonts/X11/TTF/
  15. cd ..
  16. for i in *.ttf; do
  17. install -m 0644 $i ${D}${prefix}/share/fonts/X11/TTF/${i}
  18. done
  19. }
  20. FILES_${PN} += "${datadir}"
  21. pkg_postinst_${PN} () {
  22. set -x
  23. for fontdir in `find $D/usr/lib/X11/fonts -type d`; do
  24. mkfontdir $fontdir
  25. mkfontscale $fontdir
  26. done
  27. for fontdir in `find $D/usr/share/fonts/X11 -type d`; do
  28. mkfontdir $fontdir
  29. mkfontscale $fontdir
  30. done
  31. }