ttf-liberation-sans-narrow_1.07.4.bb 1.3 KB

12345678910111213141516171819202122232425262728293031323334
  1. require ttf.inc
  2. SUMMARY = "Liberation(tm) Fonts"
  3. DESCRIPTION = "The Liberation(tm) Fonts is a font family originally \
  4. created by Ascender(c) which aims at metric compatibility with \
  5. Arial, Times New Roman, Courier New."
  6. HOMEPAGE = "https://fedorahosted.org/liberation-fonts/"
  7. LICENSE = "GPLv2"
  8. LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
  9. SRC_URI = "https://releases.pagure.org/liberation-fonts/liberation-fonts-ttf-${PV}.tar.gz \
  10. file://30-0-liberation-sans-narrow.conf \
  11. "
  12. SRC_URI[md5sum] = "134d8262145fc793c6af494dcace3e71"
  13. SRC_URI[sha256sum] = "61a7e2b6742a43c73e8762cdfeaf6dfcf9abdd2cfa0b099a9854d69bc4cfee5c"
  14. S = "${WORKDIR}/liberation-fonts-ttf-${PV}"
  15. do_install_append () {
  16. install -d ${D}${datadir}/fonts/TTF/
  17. install -d ${D}${sysconfdir}/fonts/conf.d/
  18. install -m 0644 LiberationSansNarrow*.ttf ${D}${datadir}/fonts/TTF/
  19. install -D -m 0644 ${WORKDIR}/30-0-liberation-sans-narrow.conf ${D}${sysconfdir}/conf.avail/30-${PN}-sans.conf
  20. install -D -m 0644 ${S}/License.txt ${D}${datadir}/licenses/${PN}/LICENSE
  21. # normal liberation fonts come from ttf-liberation recipe so delete here
  22. rm -rf ${D}${datadir}/fonts/truetype
  23. }
  24. PACKAGES = "${PN}"
  25. FONT_PACKAGES = "${PN}"
  26. FILES_${PN} = "${datadir}/fonts ${sysconfdir} ${datadir}/licenses"