source-han-sans-tw-fonts_1.004.bb 1.0 KB

12345678910111213141516171819202122232425262728293031323334
  1. require ttf.inc
  2. SUMMARY = "Adobe OpenType Pan-CJK font family for Traditional Chinese"
  3. HOMEPAGE = "https://github.com/adobe-fonts/source-han-sans"
  4. LICENSE = "OFL-1.1"
  5. LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=55719faa0112708e946b820b24b14097"
  6. inherit allarch fontcache
  7. # Download tends to break - so - or not?
  8. #EXCLUDE_FROM_WORLD = "1"
  9. SRC_URI = " \
  10. https://github.com/adobe-fonts/source-han-sans/raw/release/SubsetOTF/SourceHanSansTW.zip \
  11. file://44-source-han-sans-tw.conf \
  12. "
  13. SRC_URI[md5sum] = "6533b71b31c19e548768f0fc963202f3"
  14. SRC_URI[sha256sum] = "92ba161921c5cdec5a8f8d5711676f0865b50cee071c25eb4bd4125b5af59fd0"
  15. S = "${WORKDIR}/SourceHanSansTW"
  16. do_install() {
  17. install -d ${D}${sysconfdir}/fonts/conf.d/
  18. install -m 0644 ${WORKDIR}/44-source-han-sans-tw.conf ${D}${sysconfdir}/fonts/conf.d/
  19. install -d ${D}${datadir}/fonts/truetype/
  20. find ./ -name '*.otf' -exec install -m 0644 {} ${D}${datadir}/fonts/truetype/ \;
  21. }
  22. FILES_${PN} = " \
  23. ${sysconfdir}/fonts \
  24. ${datadir}/fonts \
  25. "