source-code-pro-fonts_2.030_1.050.bb 950 B

1234567891011121314151617181920212223242526272829
  1. require ttf.inc
  2. SUMMARY = "Adobe Source Code Pro"
  3. HOMEPAGE = "https://github.com/adobe-fonts/source-code-pro"
  4. LICENSE = "OFL-1.1"
  5. LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c7c16bdc2c96af797293d68503e5c65c"
  6. inherit allarch fontcache
  7. SRC_URI = " \
  8. https://github.com/adobe-fonts/source-code-pro/releases/download/2.030R-ro/1.050R-it/source-code-pro-2.030R-ro-1.050R-it.zip \
  9. file://44-source-code-pro-fonts-fontconfig.conf \
  10. "
  11. SRC_URI[sha256sum] = "da2ac159497d31b0c6d9daa8fc390fb8252e75b4a9805ace6a2c9cccaed4932e"
  12. S = "${WORKDIR}/source-code-pro-2.030R-ro-1.050R-it"
  13. do_install() {
  14. install -d ${D}${sysconfdir}/fonts/conf.d/
  15. install -m 0644 ${WORKDIR}/44-source-code-pro-fonts-fontconfig.conf ${D}${sysconfdir}/fonts/conf.d/
  16. install -d ${D}${datadir}/fonts/truetype/
  17. find ./ -name '*.otf' -exec install -m 0644 {} ${D}${datadir}/fonts/truetype/ \;
  18. }
  19. FILES_${PN} = " \
  20. ${sysconfdir}/fonts \
  21. ${datadir}/fonts \
  22. "