tslib_1.22.bb 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081
  1. SUMMARY = "An abstraction layer for touchscreen panel events"
  2. DESCRIPTION = "Tslib is an abstraction layer for touchscreen panel \
  3. events, as well as a filter stack for the manipulation of those events. \
  4. Tslib is generally used on embedded devices to provide a common user \
  5. space interface to touchscreen functionality."
  6. HOMEPAGE = "http://tslib.org/"
  7. AUTHOR = "Martin Kepplinger <martink@posteo.de>"
  8. SECTION = "base"
  9. LICENSE = "LGPLv2+ & GPLv2+"
  10. LIC_FILES_CHKSUM = "\
  11. file://COPYING;md5=fc178bcd425090939a8b634d1d6a9594 \
  12. file://tests/COPYING;md5=a23a74b3f4caf9616230789d94217acb \
  13. "
  14. SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.tar.xz;downloadfilename=tslib-${PV}.tar.xz \
  15. file://ts.conf \
  16. file://tslib.sh \
  17. "
  18. SRC_URI[sha256sum] = "aaf0aed410a268d7b51385d07fe4d9d64312038e87c447ec8a24c8db0a15617a"
  19. UPSTREAM_CHECK_URI = "https://github.com/kergoth/tslib/releases"
  20. inherit autotools pkgconfig
  21. PACKAGECONFIG ??= "debounce dejitter iir linear median pthres skip lowpass invert variance input touchkit waveshare"
  22. PACKAGECONFIG[debounce] = "--enable-debounce,--disable-debounce"
  23. PACKAGECONFIG[dejitter] = "--enable-dejitter,--disable-dejitter"
  24. PACKAGECONFIG[iir] = "--enable-iir,--disable-iir"
  25. PACKAGECONFIG[linear] = "--enable-linear,--disable-linear"
  26. PACKAGECONFIG[median] = "--enable-median,--disable-median"
  27. PACKAGECONFIG[pthres] = "--enable-pthres,--disable-pthres"
  28. PACKAGECONFIG[skip] = "--enable-skip,--disable-skip"
  29. PACKAGECONFIG[lowpass] = "--enable-lowpass,--disable-lowpass"
  30. PACKAGECONFIG[invert] = "--enable-invert,--disable-invert"
  31. PACKAGECONFIG[variance] = "--enable-variance,--disable-variance"
  32. PACKAGECONFIG[input] = "--enable-input,--disable-input"
  33. PACKAGECONFIG[tatung] = "--enable-tatung,--disable-tatung"
  34. PACKAGECONFIG[touchkit] = "--enable-touchkit,--disable-touchkit"
  35. PACKAGECONFIG[waveshare] = "--enable-waveshare,--disable-waveshare"
  36. PACKAGECONFIG[ucb1x00] = "--enable-ucb1x00,--disable-ucb1x00"
  37. PACKAGECONFIG[mk712] = "--enable-mk712,--disable-mk712"
  38. PACKAGECONFIG[h3600] = "--enable-h3600,--disable-h3600"
  39. PACKAGECONFIG[dmc] = "--enable-dmc,--disable-dmc"
  40. PACKAGECONFIG[linear-h2200] = "--enable-linear-h2200,--disable-linear-h2200"
  41. PACKAGECONFIG[corgi] = "--enable-corgi,--disable-corgi"
  42. PACKAGECONFIG[collie] = "--enable-collie,--disable-collie"
  43. PACKAGECONFIG[arctic2] = "--enable-arctic2,--disable-arctic2"
  44. PACKAGECONFIG[dmc_dus3000] = "--enable-dmc_dus3000,--disable-dmc_dus3000"
  45. PACKAGECONFIG[cy8mrln-palmpre] = "--enable-cy8mrln-palmpre,--disable-cy8mrln-palmpre"
  46. PACKAGECONFIG[galax] = "--enable-galax,--disable-galax"
  47. PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
  48. do_install_prepend() {
  49. install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
  50. }
  51. do_install_append() {
  52. install -d ${D}${sysconfdir}/profile.d/
  53. install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
  54. }
  55. RPROVIDES_tslib-conf = "libts-0.0-conf"
  56. PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate tslib-uinput"
  57. DEBIAN_NOAUTONAME_tslib-conf = "1"
  58. DEBIAN_NOAUTONAME_tslib-tests = "1"
  59. DEBIAN_NOAUTONAME_tslib-calibrate = "1"
  60. DEBIAN_NOAUTONAME_tslib-uinput = "1"
  61. RDEPENDS_${PN} = "tslib-conf"
  62. RRECOMMENDS_${PN} = "pointercal"
  63. FILES_${PN}-dev += "${libdir}/ts/*.la"
  64. FILES_tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib"
  65. FILES_${PN} = "${libdir}/*.so.* ${libdir}/ts/*.so*"
  66. FILES_tslib-calibrate += "${bindir}/ts_calibrate"
  67. FILES_tslib-uinput += "${bindir}/ts_uinput"
  68. FILES_tslib-tests = "${bindir}/ts_harvest ${bindir}/ts_print ${bindir}/ts_print_raw ${bindir}/ts_print_mt \
  69. ${bindir}/ts_test ${bindir}/ts_test_mt ${bindir}/ts_verify ${bindir}/ts_finddev ${bindir}/ts_conf"