renderdoc_1.7.bb 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738
  1. SUMMARY = "RenderDoc recipe providing renderdoccmd"
  2. DESCRIPTION = "RenderDoc is a frame-capture based graphics debugger"
  3. HOMEPAGE = "https://github.com/baldurk/renderdoc"
  4. LICENSE = "MIT"
  5. LIC_FILES_CHKSUM = "file://LICENSE.md;md5=df7ea9e196efc7014c124747a0ef9772"
  6. SRCREV = "a56af589d94dc851809fd5344d0ae441da70c1f2"
  7. SRC_URI = "git://github.com/baldurk/${BPN}.git;protocol=http;branch=v1.x \
  8. file://0001-renderdoc-use-xxd-instead-of-cross-compiling-shim-bi.patch \
  9. file://0001-Remove-glslang-pool_allocator-setAllocator.patch \
  10. "
  11. S = "${WORKDIR}/git"
  12. DEPENDS += "virtual/libx11 virtual/libgl libxcb xcb-util-keysyms vim-native"
  13. RDEPENDS_${PN} = "libxcb xcb-util-keysyms"
  14. inherit cmake python3native features_check
  15. REQUIRED_DISTRO_FEATURES = "x11 opengl"
  16. python __anonymous () {
  17. # only works on glibc systems
  18. if d.getVar('TCLIBC') != "glibc":
  19. raise bb.parse.SkipRecipe("incompatible with %s C library" % d.getVar('TCLIBC'))
  20. }
  21. COMPATIBLE_HOST = "(x86_64|i.86|arm|aarch64).*-linux"
  22. EXTRA_OECMAKE += "\
  23. -DENABLE_QRENDERDOC=OFF \
  24. -DENABLE_PYRENDERDOC=OFF \
  25. -DENABLE_RENDERDOCCMD=ON \
  26. -DCMAKE_BUILD_TYPE=Release \
  27. "
  28. FILES_${PN} += "${libdir}"
  29. FILES_${PN}-dev = "${includedir}"