openbox_3.6.1.bb 2.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. SUMMARY = "openbox Window Manager"
  2. SECTION = "x11/wm"
  3. DEPENDS = "glib-2.0 pango libxml2 virtual/libx11 libcroco librsvg gdk-pixbuf"
  4. LICENSE = "GPLv2+"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
  6. SRC_URI = " \
  7. http://icculus.org/openbox/releases/openbox-${PV}.tar.gz \
  8. file://0001-Makefile.am-avoid-race-when-creating-autostart-direc.patch \
  9. file://0001-openbox-xdg-autostart-convert-to-python3.patch \
  10. "
  11. SRC_URI[md5sum] = "b72794996c6a3ad94634727b95f9d204"
  12. SRC_URI[sha256sum] = "8b4ac0760018c77c0044fab06a4f0c510ba87eae934d9983b10878483bde7ef7"
  13. inherit autotools gettext update-alternatives pkgconfig features_check
  14. # depends on virtual/libx11
  15. REQUIRED_DISTRO_FEATURES = "x11"
  16. ALTERNATIVE_${PN}-core = "x-window-manager x-session-manager"
  17. ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/openbox"
  18. ALTERNATIVE_PRIORITY[x-window-manager] = "10"
  19. ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/openbox-session"
  20. ALTERNATIVE_PRIORITY[x-session-manager] = "100"
  21. PACKAGECONFIG ??= ""
  22. PACKAGECONFIG[imlib2] = "--enable-imlib2,--disable-imlib2,imlib2"
  23. PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
  24. PACKAGECONFIG[xrandr] = "--enable-xrandr,--disable-xrandr,libxrandr"
  25. PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama"
  26. PACKAGECONFIG[xcursor] = "--enable-xcursor,--disable-xcursor,libxcursor"
  27. PACKAGES =+ "${PN}-core ${PN}-lxde ${PN}-gnome ${PN}-config"
  28. PACKAGES_DYNAMIC += "^${PN}-theme-.*"
  29. python populate_packages_prepend() {
  30. theme_dir = d.expand('${datadir}/themes/')
  31. theme_name = d.expand('${PN}-theme-%s')
  32. do_split_packages(d, theme_dir, '(.*)', theme_name, '${PN} theme for %s', extra_depends='', allow_dirs=True)
  33. }
  34. FILES_${PN}-core = "${bindir}/openbox ${bindir}/openbox-session ${libdir}/*${SOLIBS}"
  35. FILES_${PN}-lxde += "${datadir}/lxde/ \
  36. ${datadir}/lxpanel \
  37. ${datadir}/xsessions \
  38. ${datadir}/icons"
  39. FILES_${PN}-gnome += " \
  40. ${bindir}/openbox-gnome-session \
  41. ${datadir}/gnome \
  42. ${datadir}/gnome-session \
  43. "
  44. FILES_${PN}-config += "${sysconfdir}"
  45. RDEPENDS_${PN} += "${PN}-core ${PN}-config ${PN}-theme-clearlooks python3 python3-shell pyxdg"