gnome-themes-extra_3.28.bb 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. SUMMARY = "GTK+2 standard themes"
  2. HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/gnome-themes-standard/"
  3. BUGTRACKER = "https://bugzilla.gnome.org/"
  4. SECTION = "x11/gnome"
  5. LICENSE = "LGPL-2.1"
  6. LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1"
  7. inherit gnomebase gettext gtk-icon-cache upstream-version-is-even features_check
  8. ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
  9. DEPENDS += "intltool-native gtk+"
  10. SRC_URI[archive.md5sum] = "f9f2c6c521948da427f702372e16f826"
  11. SRC_URI[archive.sha256sum] = "7c4ba0bff001f06d8983cfc105adaac42df1d1267a2591798a780bac557a5819"
  12. EXTRA_OECONF = "--disable-gtk3-engine"
  13. do_install_append() {
  14. # Only building Adwaita, remove highcontrast files
  15. rm -rf ${D}${prefix}/share/themes/HighContrast \
  16. ${D}${prefix}/share/icons
  17. # The libtool archive file is unneeded with shared libs on modern Linux
  18. rm -rf ${D}${libdir}/gtk-2.0/2.10.0/engines/libadwaita.la
  19. }
  20. # There could be gnome-theme-highcontrast as well but that requires
  21. # gtk+3 and includes lots of icons (is also broken with B != S).
  22. PACKAGES += "gnome-theme-adwaita \
  23. gnome-theme-adwaita-dark \
  24. "
  25. FILES_gnome-theme-adwaita = "${prefix}/share/themes/Adwaita \
  26. ${libdir}/gtk-2.0/2.10.0/engines/libadwaita.so"
  27. FILES_gnome-theme-adwaita-dark = "${prefix}/share/themes/Adwaita-dark"
  28. RDEPENDS_gnome-theme-adwaita-dark = "gnome-theme-adwaita"
  29. # gnome-themes-standard is empty and doesn't exist
  30. RDEPENDS_${PN}-dev = ""