sysdig_git.bb 1.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. SUMMARY = "A New System Troubleshooting Tool Built for the Way You Work"
  2. DESCRIPTION = "Sysdig is open source, system-level exploration: capture \
  3. system state and activity from a running Linux instance, then save, \
  4. filter and analyze."
  5. HOMEPAGE = "http://www.sysdig.org/"
  6. LICENSE = "Apache-2.0 & (MIT | GPL-2.0)"
  7. LIC_FILES_CHKSUM = "file://COPYING;md5=f8fee3d59797546cffab04f3b88b2d44"
  8. inherit cmake pkgconfig
  9. #OECMAKE_GENERATOR = "Unix Makefiles"
  10. JIT ?= "jit"
  11. JIT_mipsarchn32 = ""
  12. JIT_mipsarchn64 = ""
  13. JIT_riscv64 = ""
  14. JIT_riscv32 = ""
  15. DEPENDS += "lua${JIT} zlib c-ares grpc-native grpc curl ncurses jsoncpp tbb jq openssl elfutils protobuf protobuf-native jq-native"
  16. RDEPENDS_${PN} = "bash"
  17. SRC_URI = "git://github.com/draios/sysdig.git;branch=dev \
  18. file://0001-fix-build-with-LuaJIT-2.1-betas.patch \
  19. file://0001-Fix-build-with-musl-backtrace-APIs-are-glibc-specifi.patch \
  20. file://fix-uint64-const.patch \
  21. file://aarch64.patch \
  22. "
  23. SRCREV = "8daeef8da752c5f07f439391bc20c5948eb11470"
  24. PV = "0.26.6"
  25. S = "${WORKDIR}/git"
  26. EXTRA_OECMAKE = "\
  27. -DBUILD_DRIVER=OFF \
  28. -DUSE_BUNDLED_DEPS=OFF \
  29. -DUSE_BUNDLED_B64=ON \
  30. -DCREATE_TEST_TARGETS=OFF \
  31. -DDIR_ETC=${sysconfdir} \
  32. -DLUA_INCLUDE_DIR=${STAGING_INCDIR}/luajit-2.1 \
  33. -DLUA_LIBRARY=libluajit-5.1.so \
  34. "
  35. FILES_${PN} += " \
  36. ${DIR_ETC}/* \
  37. ${datadir}/zsh/* \
  38. ${prefix}/src/* \
  39. "
  40. # Use getaddrinfo_a is a GNU extension in libsinsp
  41. # It should be fixed in sysdig, until then disable
  42. # on musl
  43. # Something like this https://code.videolan.org/ePirat/vlc/-/commit/01fd9fe4c7f6c5558f7345f38abf0152e17853ab is needed to fix it
  44. COMPATIBLE_HOST_libc-musl = "null"
  45. COMPATIBLE_HOST_mips = "null"
  46. COMPATIBLE_HOST_riscv64 = "null"
  47. COMPATIBLE_HOST_riscv32 = "null"