nicstat_1.95.bb 918 B

12345678910111213141516171819202122
  1. DESCRIPTION = "nicstat is a Solaris and Linux command-line that prints out network \
  2. statistics for all network interface cards (NICs), including packets, kilobytes \
  3. per second, average packet sizes and more."
  4. HOMEPAGE = "http://nicstat.sourceforge.net"
  5. LICENSE = "Artistic-2.0"
  6. LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b4a94da2a1f918b217ef5156634fc9e0"
  7. SRC_URI = "http://softlayer-sng.dl.sourceforge.net/project/${BPN}/${BP}.tar.gz \
  8. file://0001-nicstat.c-Do-not-define-uint64_t-and-uint32_t.patch \
  9. "
  10. SRC_URI[md5sum] = "9a0b87bbc670c1e738e5b40c7afd184d"
  11. SRC_URI[sha256sum] = "c4cc33f8838f4523f27c3d7584eedbe59f4c587f0821612f5ac2201adc18b367"
  12. do_compile() {
  13. ${CC} ${CFLAGS} ${LDFLAGS} -o nicstat nicstat.c
  14. }
  15. do_install() {
  16. install -d ${D}/${bindir}/
  17. install -d ${D}/${mandir}/
  18. install -m 0755 ${S}/nicstat ${D}${bindir}/
  19. install -m 0644 ${S}/nicstat.1 ${D}/${mandir}/
  20. }