libqb_1.0.5.bb 2.2 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. SUMMARY = "An IPC library for high performance servers"
  2. DESCRIPTION = "libqb is a library with the primary purpose of providing high performance client server reusable features. \
  3. It provides high performance logging, tracing, ipc, and poll."
  4. HOMEPAGE = "https://github.com/clusterlabs/libqb/wiki"
  5. SECTION = "libs"
  6. LICENSE = "LGPL-2.1"
  7. LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785"
  8. inherit autotools pkgconfig
  9. # v1.0.5
  10. SRCREV = "d08dbcf08b0da418bce9b5427dfd89522916322a"
  11. SRC_URI = "git://github.com/ClusterLabs/${BPN}.git;branch=version_1 \
  12. file://0001-build-fix-configure-script-neglecting-re-enable-out-.patch \
  13. "
  14. S = "${WORKDIR}/git"
  15. # otherwise do_configure fails
  16. # configure:21609: checking whether linker workaround for orphan sections usable
  17. # configure:21639: i586-oe-linux-gcc -m32 -march=i586 --sysroot=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot -o conftest -O -fno-omit-frame-pointer -g -feliminate-unused-debug-types -fdebug-prefix-map=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0=/usr/src/debug/libqb/1.0.3+gitAUTOINC+c235284b5f-r0 -fdebug-prefix-map=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot= -fdebug-prefix-map=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native= -pipe -pthread -D_REENTRANT -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,conftest.ld conftest.c >&5
  18. # WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native/usr/bin/i586-oe-linux/../../libexec/i586-oe-linux/gcc/i586-oe-linux/8.1.0/ld: error: conftest.ld: SECTIONS seen after other input files; try -T/--script
  19. # WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native/usr/bin/i586-oe-linux/../../libexec/i586-oe-linux/gcc/i586-oe-linux/8.1.0/ld: internal error in write_sections, at ../../gold/reloc.cc:791
  20. # collect2: error: ld returned 1 exit status
  21. NOSECTION_FALLBACK = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', '--enable-nosection-fallback', '', d)}"
  22. NOSECTION_FALLBACK_toolchain-clang_mips64 = "--enable-nosection-fallback"
  23. EXTRA_OECONF += "${NOSECTION_FALLBACK}"
  24. CFLAGS += "-pthread -D_REENTRANT"
  25. do_configure_prepend() {
  26. ( cd ${S}
  27. ${S}/autogen.sh )
  28. }
  29. BBCLASSEXTEND = "native"