libexecinfo_1.1.bb 1.2 KB

12345678910111213141516171819202122232425262728293031
  1. # Copyright (C) 2017 Khem Raj <raj.khem@gmail.com>
  2. # Released under the MIT license (see COPYING.MIT for the terms)
  3. DESCRIPTION = "A quick-n-dirty BSD licensed clone of the GNU libc backtrace facility."
  4. HOMEPAGE = "http://www.freshports.org/devel/libexecinfo"
  5. LIC_FILES_CHKSUM = "file://execinfo.c;endline=25;md5=85bd3fa4ea9acae5182e29db063fe2e5"
  6. LICENSE = "BSD-2-Clause"
  7. SECTION = "libs"
  8. DEPENDS = ""
  9. SRC_URI = "http://distcache.freebsd.org/local-distfiles/itetcu/${BP}.tar.bz2 \
  10. file://0001-makefile-Fix-build-on-linux.patch \
  11. file://0002-execinfo-Fix-compiler-errors-found-with-newer-gcc-cl.patch \
  12. "
  13. SRC_URI[md5sum] = "8e9e81c554c1c5d735bc877448e92b91"
  14. SRC_URI[sha256sum] = "c9a21913e7fdac8ef6b33250b167aa1fc0a7b8a175145e26913a4c19d8a59b1f"
  15. CFLAGS += "-fno-omit-frame-pointer -D_GNU_SOURCE"
  16. do_install() {
  17. install -D -m 0744 ${S}/execinfo.h ${D}${includedir}/execinfo.h
  18. install -D -m 0744 ${S}/stacktraverse.h ${D}${includedir}/stacktraverse.h
  19. install -D -m 0744 ${B}/libexecinfo.a ${D}${libdir}/libexecinfo.a
  20. install -D -m 0755 ${B}/libexecinfo.so.1 ${D}${libdir}/libexecinfo.so.1
  21. ln -s libexecinfo.so.1 ${D}${libdir}/libexecinfo.so
  22. }
  23. #
  24. # We will skip parsing for non-musl systems
  25. #
  26. COMPATIBLE_HOST = ".*-musl.*"