libcec_6.0.2.bb 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. SUMMARY = "USB CEC Adaptor communication Library"
  2. HOMEPAGE = "http://libcec.pulse-eight.com/"
  3. LICENSE = "GPLv2+"
  4. LIC_FILES_CHKSUM = "file://COPYING;md5=b3a719e97f49e4841e90573f9b1a98ac"
  5. DEPENDS = "p8platform udev ncurses swig-native python3"
  6. DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}"
  7. DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}"
  8. SRCREV = "29d82c80bcc62be2878a9ac080de7eb286c4beb9"
  9. SRC_URI = "git://github.com/Pulse-Eight/libcec.git;branch=release \
  10. file://0001-CheckPlatformSupport.cmake-Do-not-hardcode-lib-path.patch \
  11. file://0001-Enhance-reproducibility.patch \
  12. file://0001-Remove-buggy-test-confusing-host-and-target.patch \
  13. "
  14. S = "${WORKDIR}/git"
  15. inherit cmake pkgconfig
  16. # default config is for RaspberryPi API, use the Linux 4.10+ API by default
  17. PLATFORM_CMAKE_FLAGS ?= "-DHAVE_LINUX_API=1 -DHAVE_RPI_API=0"
  18. EXTRA_OECMAKE += "${PLATFORM_CMAKE_FLAGS}"
  19. # Put client examples into separate packages
  20. PACKAGE_BEFORE_PN += "${PN}-examples-python ${PN}-examples"
  21. FILES_${PN}-examples-python = "${bindir}/py*"
  22. FILES_${PN}-examples = "${bindir}"
  23. RDEPENDS_${PN}-examples-python = "python3-${BPN} python3-core"
  24. # Create the wrapper for python3
  25. PACKAGES += "python3-${BPN}"
  26. FILES_python3-${BPN} = "${libdir}/python3* ${bindir}/py*"
  27. RDEPENDS_${PN} = "python3-core"
  28. # cec-client and xbmc need the .so present to work :(
  29. FILES_${PN} += "${libdir}/*.so"
  30. INSANE_SKIP_${PN} = "dev-so"
  31. # Adapter shows up as a CDC-ACM device
  32. RRECOMMENDS_${PN} = "kernel-module-cdc-acm"