xerces-c_3.1.4.bb 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. SUMMARY = "Xerces-c is a validating xml parser written in C++"
  2. DESCRIPTION = "Xerces-C++ makes it easy to give your application \
  3. the ability to read and write XML data. \
  4. A shared library is provided for parsing, generating, \
  5. manipulating, and validating XML documents using \
  6. the DOM, SAX, and SAX2 APIs."
  7. HOMEPAGE = "http://xerces.apache.org/xerces-c/"
  8. SECTION = "libs"
  9. LICENSE = "Apache-2.0"
  10. LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
  11. SRC_URI = "http://archive.apache.org/dist/xerces/c/3/sources/${BP}.tar.bz2"
  12. SRC_URI[md5sum] = "d04ae9d8b2dee2157c6db95fa908abfd"
  13. SRC_URI[sha256sum] = "9408f12c1628ecf80730bedbe8b2caad810edd01bb4c66f77b60c873e8cc6891"
  14. inherit autotools
  15. PACKAGECONFIG ??= "curl icu"
  16. PACKAGECONFIG[curl] = "--with-curl=${STAGING_DIR_TARGET}${prefix},--with-curl=no,curl"
  17. PACKAGECONFIG[icu] = "--with-icu=${STAGING_DIR_TARGET}${prefix},--with-icu=no,icu"
  18. do_install_prepend () {
  19. sed -i -e 's:-L${STAGING_DIR}/lib:-L\$\{libdir\}:g' ${B}/xerces-c.pc
  20. }
  21. PACKAGES = "libxerces-c \
  22. libxerces-c-dev \
  23. xerces-c-samples \
  24. libxerces-c-staticdev \
  25. ${PN}-dbg \
  26. "
  27. RPROVIDES_${PN}-dbg += "libxerces-c-dbg xerces-c-samples-dbg"
  28. FILES_libxerces-c = "${libdir}/libxerces-c-3.1.so"
  29. FILES_libxerces-c-dev = "${libdir}/lib*.la \
  30. ${libdir}/libxerces-c.so \
  31. ${libdir}/pkgconfig/xerces-c.pc \
  32. ${includedir}/xercesc \
  33. "
  34. FILES_xerces-c-samples = "${bindir}/*"
  35. FILES_libxerces-c-staticdev = "${libdir}/lib*.a"
  36. BBCLASSEXTEND = "native"