protobuf-c_1.3.3.bb 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. SUMMARY = "Protocol Buffers - structured data serialisation mechanism"
  2. DESCRIPTION = "This is protobuf-c, a C implementation of the Google Protocol Buffers data \
  3. serialization format. It includes libprotobuf-c, a pure C library that \
  4. implements protobuf encoding and decoding, and protoc-c, a code generator that \
  5. converts Protocol Buffer .proto files to C descriptor code, based on the \
  6. original protoc. protobuf-c formerly included an RPC implementation; that code \
  7. has been split out into the protobuf-c-rpc project."
  8. HOMEPAGE = "https://github.com/protobuf-c/protobuf-c"
  9. SECTION = "console/tools"
  10. LICENSE = "BSD-2-Clause"
  11. LIC_FILES_CHKSUM = "file://LICENSE;md5=cb901168715f4782a2b06c3ddaefa558"
  12. DEPENDS = "protobuf-native protobuf"
  13. SRCREV = "f20a3fa131c275a0e795d99a28f94b4dbbb5af26"
  14. SRC_URI = "git://github.com/protobuf-c/protobuf-c.git \
  15. file://0001-avoid-race-condition.patch \
  16. "
  17. S = "${WORKDIR}/git"
  18. inherit autotools pkgconfig
  19. # After several fix attempts there is still a race between generating
  20. # t.test-full.pb.h and compiling cxx_generate_packed_data.c despite
  21. # BUILT_SOURCES and explicit dependencies.
  22. PARALLEL_MAKE = ""
  23. PACKAGE_BEFORE_PN = "${PN}-compiler"
  24. FILES_${PN}-compiler = "${bindir}"
  25. RDEPENDS_${PN}-compiler = "protobuf-compiler"
  26. RDEPENDS_${PN}-dev += "${PN}-compiler"
  27. BBCLASSEXTEND = "native nativesdk"