nlohmann-json_3.9.1.bb 721 B

12345678910111213141516171819202122232425262728
  1. SUMMARY = "JSON for modern C++"
  2. HOMEPAGE = "https://nlohmann.github.io/json/"
  3. SECTION = "libs"
  4. LICENSE = "MIT"
  5. LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=dd0607f896f392c8b7d0290a676efc24"
  6. SRC_URI = "git://github.com/nlohmann/json.git;nobranch=1 \
  7. "
  8. SRCREV = "db78ac1d7716f56fc9f1b030b715f872f93964e4"
  9. S = "${WORKDIR}/git"
  10. inherit cmake
  11. EXTRA_OECMAKE += "-DJSON_BuildTests=OFF"
  12. # nlohmann-json is a header only C++ library, so the main package will be empty.
  13. RDEPENDS_${PN}-dev = ""
  14. BBCLASSEXTEND = "native nativesdk"
  15. # other packages commonly reference the file directly as "json.hpp"
  16. # create symlink to allow this usage
  17. do_install_append() {
  18. ln -s nlohmann/json.hpp ${D}${includedir}/json.hpp
  19. }