nlohmann-fifo_git.bb 628 B

1234567891011121314151617181920212223242526
  1. SUMMARY = "fifo maps for c++"
  2. HOMEPAGE = "https://github.com/nlohmann/fifo_map"
  3. SECTION = "libs"
  4. LICENSE = "MIT"
  5. LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=b67209a1e36b682a8226de19d265b1e0"
  6. SRC_URI = "git://github.com/nlohmann/fifo_map.git"
  7. PV = "1.0.0+git${SRCPV}"
  8. SRCREV = "0dfbf5dacbb15a32c43f912a7e66a54aae39d0f9"
  9. UPSTREAM_CHECK_COMMITS = "1"
  10. S = "${WORKDIR}/git"
  11. # nlohmann-fifo is a header only C++ library, so the main package will be empty.
  12. RDEPENDS_${PN}-dev = ""
  13. BBCLASSEXTEND = "native nativesdk"
  14. do_install() {
  15. install -d ${D}${includedir}
  16. install -m 0644 ${S}/src/fifo_map.hpp ${D}${includedir}
  17. }