ltrace_git.bb 1.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. SUMMARY = "ltrace intercepts and records dynamic library calls"
  2. DESCRIPTION = "ltrace intercepts and records dynamic library calls \
  3. which are called by an executed process and the signals received by that process. \
  4. It can also intercept and print the system calls executed by the program.\
  5. "
  6. HOMEPAGE = "http://ltrace.org/"
  7. LICENSE = "GPLv2"
  8. LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
  9. PE = "1"
  10. PV = "7.91+git${SRCPV}"
  11. SRCREV = "c22d359433b333937ee3d803450dc41998115685"
  12. DEPENDS = "elfutils"
  13. SRC_URI = "git://github.com/sparkleholic/ltrace.git;branch=master;protocol=http \
  14. file://configure-allow-to-disable-selinux-support.patch \
  15. file://0001-replace-readdir_r-with-readdir.patch \
  16. file://0001-Use-correct-enum-type.patch \
  17. file://0002-Fix-const-qualifier-error.patch \
  18. file://0001-ARM-code-has-unreachable-code-after-switch-statement.patch \
  19. file://0001-Fix-tautological-compare-warning.patch \
  20. file://0001-Add-support-for-mips64-n32-n64.patch \
  21. file://0001-configure-Recognise-linux-musl-as-a-host-OS.patch \
  22. file://0001-mips-plt.c-Delete-include-error.h.patch \
  23. file://0001-move-fprintf-into-same-block-where-modname-and-symna.patch \
  24. file://0001-hook-Do-not-append-int-to-std-string.patch \
  25. file://include_unistd_nr.patch \
  26. file://0001-Bug-fix-for-data-type-length-judgment.patch \
  27. file://0001-ensure-the-struct-pointers-are-null-initilized.patch \
  28. "
  29. S = "${WORKDIR}/git"
  30. inherit autotools
  31. PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)}"
  32. PACKAGECONFIG[unwind] = "--with-libunwind,--without-libunwind,libunwind"
  33. PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux"
  34. COMPATIBLE_HOST_riscv64 = "null"
  35. COMPATIBLE_HOST_riscv32 = "null"
  36. do_configure_prepend () {
  37. ( cd ${S}; ./autogen.sh )
  38. }