kconfig-frontends_4.11.0.1.bb 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
  2. # Released under the MIT license (see COPYING.MIT for the terms)
  3. SUMMARY = "Linux kernel style configuration framework for other projects"
  4. DESCRIPTION = "The kconfig-frontends project aims at centralising \
  5. the effort of keeping an up-to-date, out-of-tree, packaging of the \
  6. kconfig infrastructure, ready for use by third-party projects. \
  7. The kconfig-frontends package provides the kconfig parser, as well as all \
  8. the frontends"
  9. HOMEPAGE = "https://gitlab.com/ymorin/kconfig-frontends"
  10. LICENSE = "GPL-2.0"
  11. LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
  12. SECTION = "devel"
  13. DEPENDS += "ncurses flex-native gperf-native bison-native"
  14. RDEPENDS_${PN} += "python3 bash"
  15. SRC_URI = "git://gitlab.com/ymorin/kconfig-frontends.git;protocol=https;branch=4.11.x \
  16. file://0001-Makefile-ensure-frontends-exits-before-writing-into-.patch \
  17. file://0001-Switch-utils-kconfig-diff-to-use-Python-3.patch"
  18. SRCREV = "f22fce3a308be1c7790ebefc6bbedb33c5f7c86a"
  19. S = "${WORKDIR}/git"
  20. inherit autotools pkgconfig
  21. do_configure_prepend () {
  22. mkdir -p ${S}/scripts/.autostuff/m4
  23. }
  24. do_install_append() {
  25. ln -s kconfig-conf ${D}${bindir}/conf
  26. ln -s kconfig-mconf ${D}${bindir}/mconf
  27. }
  28. EXTRA_OECONF += "--disable-gconf --disable-qconf"
  29. # Some packages have the version preceeding the .so instead properly
  30. # versioned .so.<version>, so we need to reorder and repackage.
  31. SOLIBS = "-${@d.getVar('PV')[:-2]}.so"
  32. FILES_SOLIBSDEV = "${libdir}/libkconfig-parser.so"
  33. BBCLASSEXTEND = "native"