json-spirit_4.08.bb 763 B

1234567891011121314151617181920212223
  1. SUMMARY = "A C++ JSON Parser/Generator Implemented with Boost Spirit."
  2. DESCRIPTION = "JSON Spirit, a C++ library that reads and writes JSON files or streams. \
  3. It is written using the Boost Spirit parser generator. If you are \
  4. already using Boost, you can use JSON Spirit without any additional \
  5. dependencies."
  6. HOMEPAGE = "https://www.codeproject.com/kb/recipes/json_spirit.aspx"
  7. SECTION = "libs"
  8. PRIORITY = "optional"
  9. LICENSE = "MIT"
  10. LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=278ef6183dec4aae1524fccc4b0113c9"
  11. DEPENDS = "boost"
  12. SRC_URI = "file://json_spirit_v${PV}.zip \
  13. file://0001-Adjust-the-cmake-files.patch \
  14. file://0001-Link-to-libatomic.patch \
  15. "
  16. S = "${WORKDIR}/json_spirit_v${PV}"
  17. inherit cmake
  18. BBCLASSEXTEND = "nativesdk"