flatbuffers_1.12.0.bb 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. SUMMARY = "Memory Efficient Serialization Library"
  2. HOMEPAGE = "https://github.com/google/flatbuffers"
  3. SECTION = "console/tools"
  4. LICENSE = "Apache-2.0"
  5. inherit python3-dir
  6. PACKAGE_BEFORE_PN = "${PN}-compiler ${PN}-${PYTHON_PN}"
  7. RDEPENDS_${PN}-compiler = "${PN}"
  8. RDEPENDS_${PN}-${PYTHON_PN} = "${PN}"
  9. RDEPENDS_${PN}-dev += "${PN}-compiler"
  10. LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
  11. SRCREV = "6df40a2471737b27271bdd9b900ab5f3aec746c7"
  12. SRC_URI = "git://github.com/google/flatbuffers.git"
  13. CXXFLAGS += "-fPIC"
  14. BUILD_CXXFLAGS += "-fPIC"
  15. # BUILD_TYPE=Release is required, otherwise flatc is not installed
  16. EXTRA_OECMAKE += "\
  17. -DCMAKE_BUILD_TYPE=Release \
  18. -DFLATBUFFERS_BUILD_TESTS=OFF \
  19. -DFLATBUFFERS_BUILD_SHAREDLIB=ON \
  20. "
  21. inherit cmake
  22. S = "${WORKDIR}/git"
  23. do_install_append() {
  24. install -d ${D}${PYTHON_SITEPACKAGES_DIR}
  25. cp -rf ${S}/python/flatbuffers ${D}${PYTHON_SITEPACKAGES_DIR}
  26. }
  27. FILES_${PN}-compiler = "${bindir}"
  28. FILES_${PN}-${PYTHON_PN} = "${PYTHON_SITEPACKAGES_DIR}"
  29. BBCLASSEXTEND = "native nativesdk"