dnf-plugin-tui_git.bb 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. SUMMARY = "A text-based user interface plugin of dnf for user to manage packages. "
  2. LICENSE = "GPLv2"
  3. LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
  4. SRC_URI = "git://github.com/ubinux/dnf-plugin-tui.git;branch=master "
  5. SRCREV = "6d3fab9b9559b6a483fe668e39c29126cdbb58d8"
  6. PV = "1.2"
  7. SRC_URI_append_class-target = " file://oe-remote.repo.sample"
  8. inherit distutils3-base
  9. S = "${WORKDIR}/git"
  10. do_install_append() {
  11. install -d ${D}${datadir}/dnf
  12. install -m 0755 ${S}/samples/* ${D}${datadir}/dnf
  13. install -d ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg
  14. install -m 0755 ${S}/dnf-plugins/mkimg/* ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg
  15. for file in $(ls ${S}/dnf-plugins/ | grep -v mkimg); do
  16. install -m 0755 ${S}/dnf-plugins/$file ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins
  17. done
  18. }
  19. do_install_append_class-target() {
  20. install -d ${D}${sysconfdir}/yum.repos.d
  21. install -m 0644 ${WORKDIR}/oe-remote.repo.sample ${D}${sysconfdir}/yum.repos.d
  22. }
  23. FILES_${PN} += "${datadir}/dnf"
  24. RDEPENDS_${PN} += " \
  25. bash \
  26. dnf \
  27. libnewt-python \
  28. "
  29. BBCLASSEXTEND = "nativesdk"
  30. PNBLACKLIST[dnf-plugin-tui] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'does not build correctly without package_rpm in PACKAGE_CLASSES', d)}"