cpuid_20200427.bb 950 B

1234567891011121314151617181920212223
  1. SUMMARY = "Linux tool to dump x86 CPUID information about the CPU(s)"
  2. DESCRIPTION = "cpuid dumps detailed information about the CPU(s) gathered \
  3. from the CPUID instruction, and also determines the exact model of CPU(s). \
  4. It supports Intel, AMD, and VIA CPUs, as well as older Transmeta, Cyrix, \
  5. UMC, NexGen, Rise, and SiS CPUs"
  6. LICENSE = "GPLv2"
  7. LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
  8. SRC_URI = "http://www.etallen.com/${BPN}/${BP}.src.tar.gz \
  9. "
  10. SRC_URI[md5sum] = "daa93ee2fdaf461e515b4713e7337076"
  11. SRC_URI[sha256sum] = "c1a9463f1f2175086120e9079e318bbd383dc1e574fafb2f724879f1d11061d4"
  12. COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
  13. inherit perlnative
  14. # The install rule from the Makefile has hardcoded paths, so we duplicate
  15. # the actions to accommodate different paths.
  16. do_install () {
  17. install -D -m 0755 ${B}/cpuid ${D}/${bindir}/cpuid
  18. install -D -m 0444 ${B}/cpuid.man.gz ${D}/${mandir}
  19. }