autoconf-2.13-native_2.13.bb 2.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. SUMMARY = "A GNU tool that produce shell scripts to automatically configure software"
  2. DESCRIPTION = "Autoconf is an extensible package of M4 macros that produce shell scripts to automatically \
  3. configure software source code packages. Autoconf creates a configuration script for a package from a template \
  4. file that lists the operating system features that the package can use, in the form of M4 macro calls."
  5. SECTION = "devel"
  6. HOMEPAGE = "http://www.gnu.org/software/autoconf/"
  7. LICENSE = "GPLv3"
  8. LICENSE = "GPLv2 & GPLv3"
  9. LIC_FILES_CHKSUM = "file://COPYING;md5=361b6b837cad26c6900a926b62aada5f"
  10. SRC_URI = " \
  11. ${GNU_MIRROR}/autoconf/autoconf-${PV}.tar.gz \
  12. file://0001-Add-config.guess-config.sub-install-to-destdir.patch \
  13. "
  14. S = "${WORKDIR}/${BPN}"
  15. SRC_URI[md5sum] = "9de56d4a161a723228220b0f425dc711"
  16. SRC_URI[sha256sum] = "f0611136bee505811e9ca11ca7ac188ef5323a8e2ef19cffd3edb3cf08fd791e"
  17. inherit native texinfo
  18. DEPENDS += "m4-native gnu-config-native"
  19. RDEPENDS_${PN} = "m4-native gnu-config-native"
  20. PERL = "${USRBINPATH}/perl"
  21. CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'"
  22. CONFIGUREOPTS = " \
  23. --build=${BUILD_SYS} \
  24. --host=${HOST_SYS} \
  25. --target=${TARGET_SYS} \
  26. --prefix=${prefix} \
  27. --exec_prefix=${exec_prefix} \
  28. --bindir=${bindir} \
  29. --sbindir=${sbindir} \
  30. --libexecdir=${libexecdir} \
  31. --datadir=${datadir} \
  32. --sysconfdir=${sysconfdir} \
  33. --sharedstatedir=${sharedstatedir} \
  34. --localstatedir=${localstatedir} \
  35. --libdir=${libdir} \
  36. --includedir=${includedir} \
  37. --oldincludedir=${oldincludedir} \
  38. --infodir=${infodir} \
  39. --mandir=${mandir} \
  40. --disable-silent-rules \
  41. "
  42. EXTRA_OECONF += "ac_cv_path_M4=m4 ac_cv_prog_TEST_EMACS=no"
  43. do_configure() {
  44. ./configure ${CONFIGUREOPTS}
  45. }
  46. do_install() {
  47. oe_runmake 'DESTDIR=${D}' install
  48. # avoid conflicts with standard autotools
  49. ver="213"
  50. for file in `find ${D}${bindir} -type f`; do
  51. mv $file $file$ver
  52. done
  53. mv ${D}${datadir}/autoconf ${D}${datadir}/autoconf213
  54. }