android-tools-conf_1.0.bb 632 B

1234567891011121314151617181920
  1. DESCRIPTION = "Different utilities from Android - corressponding configuration files"
  2. SECTION = "console/utils"
  3. LICENSE = "MIT"
  4. LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
  5. SRC_URI = "file://android-gadget-setup"
  6. PACKAGE_ARCH = "${MACHINE_ARCH}"
  7. do_install() {
  8. install -d ${D}${bindir}
  9. install -m 0755 ${WORKDIR}/android-gadget-setup ${D}${bindir}
  10. }
  11. python () {
  12. pn = d.getVar('PN')
  13. profprov = d.getVar("PREFERRED_PROVIDER_" + pn)
  14. if profprov and pn != profprov:
  15. raise bb.parse.SkipRecipe("PREFERRED_PROVIDER_%s set to %s, not %s" % (pn, profprov, pn))
  16. }