botan_2.14.0.bb 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. SUMMARY = "Crypto and TLS for C++11"
  2. HOMEPAGE = "https://botan.randombit.net"
  3. LICENSE = "BSD-2-Clause"
  4. LIC_FILES_CHKSUM = "file://license.txt;md5=a02e03c8fa2c5e7b9b3fcc1b9811fd3b"
  5. SECTION = "libs"
  6. SRC_URI = "https://botan.randombit.net/releases/Botan-${PV}.tar.xz"
  7. SRC_URI[md5sum] = "ebc68c08b99bbc4b4fc9bdbfad398b02"
  8. SRC_URI[sha256sum] = "0c10f12b424a40ee19bde00292098e201d7498535c062d8d5b586d07861a54b5"
  9. S = "${WORKDIR}/Botan-${PV}"
  10. inherit python3native siteinfo lib_package
  11. CPU ?= "${TARGET_ARCH}"
  12. CPU_x86 = "x86_32"
  13. CPU_armv7a = "armv7"
  14. CPU_armv7ve = "armv7"
  15. do_configure() {
  16. python3 ${S}/configure.py \
  17. --prefix="${D}${exec_prefix}" \
  18. --libdir="${D}${libdir}" \
  19. --cpu="${CPU}" \
  20. --cc-bin="${CXX}" \
  21. --cxxflags="${CXXFLAGS}" \
  22. --ldflags="${LDFLAGS}" \
  23. --with-endian=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \
  24. ${@bb.utils.contains("TUNE_FEATURES","neon","","--disable-neon",d)} \
  25. --with-sysroot-dir=${STAGING_DIR_HOST} \
  26. --with-build-dir="${B}" \
  27. --optimize-for-size \
  28. --with-stack-protector \
  29. --enable-shared-library \
  30. --with-python-versions=3 \
  31. ${EXTRA_OECONF}
  32. }
  33. do_compile() {
  34. oe_runmake
  35. }
  36. do_install() {
  37. oe_runmake install
  38. sed -i -e "s|${D}||g" ${D}${libdir}/pkgconfig/botan-2.pc
  39. }
  40. PACKAGES += "${PN}-python3"
  41. FILES_${PN}-python3 = "${libdir}/python3"
  42. RDEPENDS_${PN}-python3 += "python3"
  43. COMPATIBLE_HOST_riscv32 = "null"