sdbus-c++-libsystemd_243.bb 3.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970
  1. SUMMARY = "libsystemd static library"
  2. DESCRIPTION = "libsystemd static library built specifically as an integral component of sdbus-c++"
  3. SECTION = "libs"
  4. LICENSE = "LGPLv2.1+"
  5. LIC_FILES_CHKSUM = "file://LICENSE.LGPL2.1;md5=4fbd65380cdd255951079008b364516c"
  6. inherit meson pkgconfig
  7. DEPENDS += "gperf-native gettext-native util-linux libcap"
  8. SRCREV = "efb536d0cbe2e58f80e501d19999928c75e08f6a"
  9. SRCBRANCH = "v243-stable"
  10. SRC_URI = "git://github.com/systemd/systemd-stable.git;protocol=git;branch=${SRCBRANCH}"
  11. SRC_URI += "file://static-libsystemd-pkgconfig.patch"
  12. # patches needed by musl
  13. SRC_URI_append_libc-musl = " ${SRC_URI_MUSL}"
  14. SRC_URI_MUSL = "\
  15. file://0002-don-t-use-glibc-specific-qsort_r.patch \
  16. file://0003-missing_type.h-add-__compare_fn_t-and-comparison_fn_.patch \
  17. file://0004-add-fallback-parse_printf_format-implementation.patch \
  18. file://0005-src-basic-missing.h-check-for-missing-strndupa.patch \
  19. file://0006-Include-netinet-if_ether.h.patch \
  20. file://0007-don-t-fail-if-GLOB_BRACE-and-GLOB_ALTDIRFUNC-is-not.patch \
  21. file://0008-add-missing-FTW_-macros-for-musl.patch \
  22. file://0010-fix-missing-of-__register_atfork-for-non-glibc-build.patch \
  23. file://0011-Use-uintmax_t-for-handling-rlim_t.patch \
  24. file://0014-test-sizeof.c-Disable-tests-for-missing-typedefs-in-.patch \
  25. file://0015-don-t-pass-AT_SYMLINK_NOFOLLOW-flag-to-faccessat.patch \
  26. file://0016-Define-glibc-compatible-basename-for-non-glibc-syste.patch \
  27. file://0017-Do-not-disable-buffering-when-writing-to-oom_score_a.patch \
  28. file://0018-distinguish-XSI-compliant-strerror_r-from-GNU-specif.patch \
  29. file://0019-Hide-__start_BUS_ERROR_MAP-and-__stop_BUS_ERROR_MAP.patch \
  30. file://0020-missing_type.h-add-__compar_d_fn_t-definition.patch \
  31. file://0021-avoid-redefinition-of-prctl_mm_map-structure.patch \
  32. file://0024-test-json.c-define-M_PIl.patch \
  33. file://0001-do-not-disable-buffer-in-writing-files.patch \
  34. file://0002-src-login-brightness.c-include-sys-wait.h.patch \
  35. file://0003-src-basic-copy.c-include-signal.h.patch \
  36. file://0004-src-shared-cpu-set-util.h-add-__cpu_mask-definition.patch \
  37. file://0001-meson-Fix-reallocarray-check.patch \
  38. "
  39. PACKAGECONFIG ??= "gshadow idn"
  40. PACKAGECONFIG_remove_libc-musl = " gshadow idn"
  41. PACKAGECONFIG[gshadow] = "-Dgshadow=true,-Dgshadow=false"
  42. PACKAGECONFIG[idn] = "-Didn=true,-Didn=false"
  43. EXTRA_OEMESON += "-Dstatic-libsystemd=pic"
  44. S = "${WORKDIR}/git"
  45. do_compile() {
  46. ninja -v ${PARALLEL_MAKE} version.h
  47. ninja -v ${PARALLEL_MAKE} libsystemd.a
  48. }
  49. do_install () {
  50. install -d ${D}${libdir}
  51. install ${B}/libsystemd.a ${D}${libdir}
  52. install -d ${D}${includedir}/systemd
  53. install ${S}/src/systemd/*.h ${D}${includedir}/systemd
  54. install -d ${D}${libdir}/pkgconfig
  55. install ${B}/src/libsystemd/libsystemd.pc ${D}${libdir}/pkgconfig
  56. }