packagegroup-basic.bb 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # This recipe is intended as a 'simpler' replacement for packagegroup-base.
  2. # Please communicate your use cases and suggestions to the mailinglist(s)
  3. SUMMARY = "Basic task to get a device online"
  4. PR = "r13"
  5. PACKAGE_ARCH = "${MACHINE_ARCH}"
  6. inherit packagegroup
  7. # Poke extra recomendations into the list using your machine.conf
  8. #
  9. MACHINE_EXTRA_RRECOMMENDS ?= ""
  10. #
  11. # Select between dropbear and openssh
  12. # Set TASK_BASIC_SSHDAEMON = "openssh-sshd openssh-sftp openssh-sftp-server" in your DISTRO config to get openssh(d)
  13. #
  14. TASK_BASIC_SSHDAEMON ?= "dropbear openssh-sftp openssh-sftp-server"
  15. #
  16. # The section below is designed to match with packagegroup-boot, but doesn't depend on it to allow for more freedom
  17. # when writing image recipes.
  18. # It also avoids the choice between connman/networkmanager/ifupdown since that is an image feature, not a
  19. # distro feature.
  20. #
  21. # Util-linux (u)mount is included because the busybox one can't handle /etc/mtab being symlinked to /proc/mounts
  22. #
  23. RDEPENDS_${PN} = "\
  24. ${TASK_BASIC_SSHDAEMON} \
  25. avahi-daemon avahi-utils \
  26. "
  27. #
  28. # The following section is split in 3:
  29. # 1) Machine features: kernel modules and userspace helpers for those
  30. # 2) Distro features: packages associated with those
  31. # 3) Nice to have: packages that are nice to have, but aren't strictly needed
  32. #
  33. RRECOMMENDS_${PN} = "\
  34. ${MACHINE_EXTRA_RRECOMMENDS} \
  35. ${@bb.utils.contains("MACHINE_FEATURES", "usbhost", "usbutils", "", d)} \
  36. ${@bb.utils.contains("MACHINE_FEATURES", "alsa", "alsa-utils-alsamixer", "", d)} \
  37. ${@bb.utils.contains("MACHINE_FEATURES", "usbgadget", "kernel-module-g-ether kernel-module-g-serial kernel-module-g-mass-storage", "", d)} \
  38. \
  39. ${@bb.utils.contains("DISTRO_FEATURES", "bluetooth", "bluez5", "", d)} \
  40. ${@bb.utils.contains("DISTRO_FEATURES", "wifi", "iw wpa-supplicant", "", d)} \
  41. \
  42. tzdata \
  43. \
  44. cpufrequtils \
  45. htop \
  46. "